Salestrail requires Android 7 and above in order to run, so if you get the message incompatible handset from Google Play Store, it means your device is running on an older software version.

There are only 2 solutions to this problem:

  • Update your device's software. You can do this from your device's settings. However, some old devices cannot be updated to more than Android 6. That leads us to the second solution
  • Use a different device that has at least Android 7.
Did this answer your question?